Problème avec icônes .ico dans explorateur [résolu]

Optimisation de Windows, modification du bureau.

Re: voir les icones dans l'explorateur

Messagepar ml56 » Lun 14 Sep 2009 14:04

Oui, c'est vraiment bizarre...

Je ne reconnais même pas l'icône par défaut des fichiers .ico, est-elle liée au thème Windows 7 que tu as installé ? Si oui, quel est ce thème ? C'est peut-être lui qui a modifié l'option d'affichage des icônes.
Sinon, c'est qu'un de tes programmes a pris le contrôle de tes fichiers .ico ; il faudrait regarder quel est ce programme (dans Panneau de configuration > Programmes par défaut > Associer un type de fichier à un programme > Extensions .ico et .png par la même occasion).

A+
Avatar de l’utilisateur
ml56
 
Messages: 444
Inscription: Dim 17 Mai 2009 19:53
Localisation: Bretagne

Re: voir les icones dans l'explorateur

Messagepar Sai » Lun 14 Sep 2009 14:11

l'icone par defaut est celle que j'ai toujours eut.... mais en y pensant, c'est en fait celle d'ACDSee!!! ca doit etre ca le probleme!!

Le theme c'est RedIce trouvé sur DeviantArt

Merci,vais tester voir si c'est bien ca!
Sai
 
Messages: 21
Inscription: Lun 14 Sep 2009 09:58

Re: voir les icones dans l'explorateur

Messagepar Sai » Lun 14 Sep 2009 14:16

Ha ha ha ha ha!!

trop cool, ca marche!! c'etait bien ACDSee qui faisait n'importe quoi!

merci bien m'sieur!
Sai
 
Messages: 21
Inscription: Lun 14 Sep 2009 09:58

Re: voir les icones dans l'explorateur

Messagepar ml56 » Lun 14 Sep 2009 14:31

De rien ;-) Heureux pour toi :-)

Pour ceux qui auraient encore ce genre de problème sans en trouver l'origine, voici un moyen de ré-associer les fichiers .ico comme ils l'étaient par défaut à l'installation ; pour cela il faut intervenir dans la base de registre. Pour éviter les bêtises, le plus simple est de télécharger un fichier qui fera ça tout seul :

- Aller sur ce site :
http://www.winhelponline.com/articles/1 ... Vista.html

- Dans le tableau, cliquer sur .ico
Cela télécharge le fichier icofix_Vista.zip (oui, c'est marqué Vista mais dans le cas des fichiers .ico, c'est la même chose avec Windows 7, j'ai vérifié)

- Dézipper puis cliquer sur le fichier icofix_vista.reg obtenu, accepter la fusion et redémarrer le PC.

A+

EDIT :
ml56 a écrit:Je ne reconnais même pas l'icône par défaut des fichiers .ico
Et pour cause, il n'y en a pas ! A l'installation, c'est l'image de l'icône qui apparaît par défaut, donc si c'est autre chose, c'est qu'un programme tiers a OBLIGATOIREMENT pris le contrôle des fichiers .ico et le problème doit venir de lui.
Avatar de l’utilisateur
ml56
 
Messages: 444
Inscription: Dim 17 Mai 2009 19:53
Localisation: Bretagne

Re: Problème avec icônes .ico dans explorateur [résolu]

Messagepar Alex75011 » Lun 14 Sep 2009 16:53

Plus simple:

Panneau de configuration\Programmes\Programmes par défaut\Définir les associations
Avatar de l’utilisateur
Alex75011
 
Messages: 1646
Inscription: Ven 15 Mai 2009 12:12
Localisation: PARIS

Re: Problème avec icônes .ico dans explorateur [résolu]

Messagepar ml56 » Lun 14 Sep 2009 17:05

Alex75011 a écrit:Plus simple: Panneau de configuration\Programmes\Programmes par défaut\Définir les associations

Bonjour,
C'est vrai lorsqu'on veut changer l'association d'un fichier avec un autre programme que celui défini par défaut, mais pour certaines extensions - comme .ico (et, je crois, .exe et .lnk, entre autres) il n'est pas possible de revenir à l'état initial par ce chemin-là.
A+
Avatar de l’utilisateur
ml56
 
Messages: 444
Inscription: Dim 17 Mai 2009 19:53
Localisation: Bretagne

Re: Problème avec icônes .ico dans explorateur [résolu]

Messagepar Alex75011 » Lun 14 Sep 2009 17:10

Je viens de le faire et pas de problèmes.
Avatar de l’utilisateur
Alex75011
 
Messages: 1646
Inscription: Ven 15 Mai 2009 12:12
Localisation: PARIS

Re: Problème avec icônes .ico dans explorateur [résolu]

Messagepar ml56 » Lun 14 Sep 2009 17:13

Ah, alors ça m'intéresse car je n'ai pas réussi, tu as associé .ico à quel programme ?
Avatar de l’utilisateur
ml56
 
Messages: 444
Inscription: Dim 17 Mai 2009 19:53
Localisation: Bretagne

Re: Problème avec icônes .ico dans explorateur [résolu]

Messagepar Alex75011 » Lun 14 Sep 2009 18:17

1- pour tester -PAINT-
Redémarrage
2- rétablissement normal -visionneuse windows-

Bonne soirée
Avatar de l’utilisateur
Alex75011
 
Messages: 1646
Inscription: Ven 15 Mai 2009 12:12
Localisation: PARIS

Re: Problème avec icônes .ico dans explorateur [résolu]

Messagepar ml56 » Lun 14 Sep 2009 18:36

D'accord pour Paint et la visionneuse, on peut associer .ico avec ces programmes, mais ce que je voulais dire (et j'ai dû mal m'exprimer, excuse-moi) c'est qu'en passant par les programmes par défaut, on ne peut pas associer une extension avec aucun programme (c'est-à-dire, en fait, désassocier une extension de tous programmes) afin de retrouver une situation vierge (que j'appelais initiale) et l'indication "application inconnue" en face de l'extension.

Cela dit, entre-temps, j'ai tout de même trouvé un moyen (peu académique) de le faire : il faut créer un fichier .txt (sur le bureau, par exemple), le renommer en .exe et aller le chercher après avoir cliqué sur le "Changer le programme..." du "Définir les associations". Il suffit ensuite de supprimer ce faux fichier .exe et l'extension qu'on lui a associé retrouvera "application inconnue" en face d'elle. C'est une manière de nettoyer la base de registre de toutes autres indications laissées par un autre programme à propos de cette extension.

A+
Avatar de l’utilisateur
ml56
 
Messages: 444
Inscription: Dim 17 Mai 2009 19:53
Localisation: Bretagne

PrécédenteSuivante

Retourner vers Personnalisation de Windows

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

Livre photo